Multicast Konfiguration für Media Streaming Geräte

In Fortigate Netzwerk-Umgebungen mit mehreren VLANs oder mit einer Kombination aus LANs und WLANs, in denen z.B. Apple TV oder Sonos Geräte integriert werden und z.B. über Mobilgeräte gesteuert werden sollen, die sich in anderen Netzwerk-Segmenten befinden,  ist eine Multicast Konfiguration erforderlich, um die Kommunikation der Komponenten zu ermöglichen.

Multicast aktivieren

Im ersten Schritt ist die Multicast Option in den Systemeinstellungen zu aktivieren.

config system settings
	set multicast-forward enable
end
Multicast Adressen

Danach werden für die jeweiligen System Multicast Adressen angelegt.

config firewall multicast-address
    edit "Sonos"
        set start-ip 239.255.255.250
        set end-ip 239.255.255.250
    next
    edit "Apple_TV"
        set start-ip 224.0.0.251
        set end-ip 224.0.0.251
    next
end
Multicast Firewall Poliy

Um die Multicast Kommunikation nun zu ermöglichen, braucht es zwei Mulitcast Firewall-Policies zwischen den jeweiligen Interfacen, in diesem Fall zwischen internal und wifi.

config firewall multicast-policy
    edit 1
        set srcintf "internal"
        set dstintf "wifi"
        set srcaddr "all"
        set dstaddr "Sonos" "Apple_TV"
    next
    edit 2
        set srcintf "wifi"
        set dstintf "internal"
        set srcaddr "all"
        set dstaddr "Sonos" "Apple_TV"
    next
end

Quellen:
https://blog.boll.ch/apple-tv-sonos-streaming-gerate-in-fortigate-wireless-netzen/

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.